<!doctype html>
<html data-n-head="lang" data-n-head-ssr lang="en">
  <head>
    <meta data-n-head="true" charset="utf-8"><meta data-n-head="true" content="IE=edge" http-equiv="X-UA-Compatible"><meta data-n-head="true" content="no" name="msapplication-tap-highlight"><meta data-n-head="true" content="width=device-width,initial-scale=1" name="viewport"><meta data-n-head="true" content="Amplitude" data-hid="og:site_name" property="og:site_name"><meta data-n-head="true" content="summary_large_image" data-hid="twitter:card" name="twitter:card"><meta data-n-head="true" content="Mike Hutchinson" data-hid="og:title" property="og:title"><meta data-n-head="true" content="Mike Hutchinson is the Chief Product Officer at SuperAwesome" data-hid="description" name="description"><meta data-n-head="true" content="https://images.ctfassets.net/vrkkgjbn4fsk/4G06sxgcJEfvst3oa8iEYW/d2332e4e6eb92b34260312e461f96672/mike-hutchinson.jpeg" data-hid="og:image" property="og:image"><title data-n-head="true">Mike Hutchinson</title><link data-n-head="true" href="/favicon.svg" rel="icon" type="image/svg+xml"><link data-n-head="true" href="https://fonts.googleapis.com/css?display=swap&family=IBM+Plex+Sans:400,400i,600,700,700i|IBM+Plex+Serif:400,400i,600,700|IBM+Plex+Sans+Condensed:400,700" rel="stylesheet"><link data-n-head="true" href="/blog/feed.xml" rel="alternate" type="application/rss+xml" title="Amplitude Blog"><link data-n-head="true" href="https://www.amplitude.com/blog/author/mike-hutchinson" rel="canonical" data-hid="canonical"><link data-n-head="true" href="https://www.amplitude.com/blog/author/mike-hutchinson" rel="alternate" data-hid="alternate" lang="en"><script data-n-head="true" data-hid="inline-utils">const MUTINY_JS_URL = "https://client-registry.mutinycdn.com/personalize/client/6a5246eb613bf61a.js";

function getCookie(name) {
	const v = document.cookie.match("(^|;) ?" + name + "=([^;]*)(;|$)");
	return v ? v[2] : null;
};
function eraseCookie(name) {
	document.cookie = name+'=; Max-Age=-99999999;';
}
function addScript(url) {
	let s = document.createElement("script");
	s.async = true;
	s.src = url;
	document.getElementsByTagName("head")[0].appendChild(s);
};
</script><script data-n-head="true" data-hid="inline-scripts">// Cleanup corrupt CookieControl cookies
const ccName = 'CookieControl'
const ccVal = getCookie(ccName);
if (ccVal) {
	try { JSON.parse(ccVal); }
	catch (e) {
		eraseCookie(ccName)
	}
}
</script><script src="https://cdn.optimizely.com/js/5281270681.js" data-n-head="true"></script><script data-n-head="true" data-hid="optional-priority-libraries">// See comments in config file for an explanation
const cookieString = getCookie("CookieControl");
if (cookieString) {
	const cookieJson = JSON.parse(cookieString);

	// Need to check for both marketing and content for now. Clients who got the banner
	// with the old categories might have 'marketing' stored instead of 'content'.
	const didAcceptMarketing = (cookieJson.optionalCookies || {}).marketing === "accepted";
	const didAcceptContent = (cookieJson.optionalCookies || {}).content === "accepted";
	if (didAcceptMarketing || didAcceptContent) {
		addScript(MUTINY_JS_URL);
	}
}
</script><script src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-550cba475e5ca316" data-n-head="true" async data-hid="addthis"></script><style data-vue-ssr-id="72e7ad30:0">/*! normalize.css v8.0.0 | MIT License | github.com/necolas/normalize.css */html{line-height:1.15;-webkit-text-size-adjust:100%}body{margin:0}h1{font-size:2em;margin:.67em 0}hr{box-sizing:content-box;height:0;overflow:visible}pre{font-family:monospace,monospace;font-size:1em}a{background-color:transparent}abbr[title]{border-bottom:none;text-decoration:underline;text-decoration:underline dotted}b,strong{font-weight:bolder}code,kbd,samp{font-family:monospace,monospace;font-size:1em}small{font-size:80%}sub,sup{font-size:75%;line-height:0;position:relative;vertical-align:baseline}sub{bottom:-.25em}sup{top:-.5em}img{border-style:none}button,input,optgroup,select,textarea{font-family:inherit;font-size:100%;line-height:1.15;margin:0}button,input{overflow:visible}button,select{text-transform:none}[type=button],[type=reset],[type=submit],button{-webkit-appearance:button}[type=button]::-moz-focus-inner,[type=reset]::-moz-focus-inner,[type=submit]::-moz-focus-inner,button::-moz-focus-inner{border-style:none;padding:0}[type=button]:-moz-focusring,[type=reset]:-moz-focusring,[type=submit]:-moz-focusring,button:-moz-focusring{outline:1px dotted ButtonText}fieldset{padding:.35em .75em .625em}legend{box-sizing:border-box;color:inherit;display:table;max-width:100%;padding:0;white-space:normal}progress{vertical-align:baseline}textarea{overflow:auto}[type=checkbox],[type=radio]{box-sizing:border-box;padding:0}[type=number]::-webkit-inner-spin-button,[type=number]::-webkit-outer-spin-button{height:auto}[type=search]{-webkit-appearance:textfield;outline-offset:-2px}[type=search]::-webkit-search-decoration{-webkit-appearance:none}::-webkit-file-upload-button{-webkit-appearance:button;font:inherit}details{display:block}summary{display:list-item}[hidden],template{display:none}</style><style data-vue-ssr-id="56c5e208:0">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</style><style data-vue-ssr-id="0743b971:0">.vv-visual{display:inline-block;font-size:0;overflow:hidden;position:relative}.vv-block{display:block}.vv-has-width{width:100%}.vv-has-height,.vv-shim{height:100%}.vv-shim{display:inline-block}.vv-fill{display:block;position:absolute;top:0;bottom:0;left:0;right:0}.vv-fill-asset{position:absolute;width:100%;height:100%}.vv-asset[class*=vv-background-]{background-repeat:no-repeat}.vv-background-cover{background-size:cover}.vv-background-contain{background-size:contain}.vv-video.vv-background-contain,.vv-video.vv-background-cover{position:absolute;top:50%;left:50%;transform:translate(-50%,-50%)}.vv-video.vv-background-contain.vv-video-letterbox,.vv-video.vv-background-cover.vv-video-pillarbox{width:calc(100% + 1px);height:auto}.vv-video.vv-background-contain.vv-video-pillarbox,.vv-video.vv-background-cover.vv-video-letterbox{width:auto;height:calc(100% + 1px)}.vv-slot,.vv-slot-prepend{font-size:1rem;position:relative;display:inline-block}.vv-align-bottom{vertical-align:bottom}.vv-align-middle{vertical-align:middle}.vv-align-top{vertical-align:top}.vv-align-left{text-align:left}.vv-align-center{text-align:center}.vv-align-right{text-align:right}.vv-fade-enter{opacity:0}.vv-fade-enter-active{transition:opacity .3s}.vv-fade-leave-active{transition-delay:.31s}</style><style data-vue-ssr-id="4c454d79:0">.el-loading-parent--relative{position:relative!important}.el-loading-parent--hidden{overflow:hidden!important}.el-loading-mask{position:absolute;z-index:2000;background-color:hsla(0,0%,100%,.9);margin:0;top:0;right:0;bottom:0;left:0;transition:opacity .3s}.el-loading-mask.is-fullscreen{position:fixed}.el-loading-mask.is-fullscreen .el-loading-spinner{margin-top:-25px}.el-loading-mask.is-fullscreen .el-loading-spinner .circular{height:50px;width:50px}.el-loading-spinner{top:50%;margin-top:-21px;width:100%;text-align:center;position:absolute}.el-loading-spinner .el-loading-text{color:#007fd2;margin:3px 0;font-size:14px}.el-loading-spinner .circular{height:42px;width:42px;animation:loading-rotate 2s linear infinite}.el-loading-spinner .path{animation:loading-dash 1.5s ease-in-out infinite;stroke-dasharray:90,150;stroke-dashoffset:0;stroke-width:2;stroke:#007fd2;stroke-linecap:round}.el-loading-spinner i{color:#007fd2}.el-loading-fade-enter,.el-loading-fade-leave-active{opacity:0}@keyframes loading-rotate{to{transform:rotate(1turn)}}@keyframes loading-dash{0%{stroke-dasharray:1,200;stroke-dashoffset:0}50%{stroke-dasharray:90,150;stroke-dashoffset:-40px}to{stroke-dasharray:90,150;stroke-dashoffset:-120px}}</style><style data-vue-ssr-id="3b17636a:0">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</style><style data-vue-ssr-id="43bb1d12:0">.underlined-btn{display:inline-block;cursor:pointer;outline:0;user-select:none;-webkit-tap-highlight-color:transparent;touch-action:manipulation;font-family:IBM Plex Sans,sans-serif;font-weight:700;font-style:normal;font-size:1rem;color:#10069f;line-height:1;letter-spacing:.0125rem;white-space:nowrap;position:relative;padding-bottom:.375rem}.wysiwyg .underlined-btn{text-decoration:none}.wysiwyg .underlined-btn:hover{color:#10069f}.underlined-btn:after,.underlined-btn:before{position:absolute;content:"";display:block;width:100%;height:2px;background-color:#e3e7ea;left:0;bottom:0}.underlined-btn:after{background:#10069f;width:0;transition:width .5s cubic-bezier(.77,0,.175,1)}.no-touchevents .underlined-btn:active:after,.no-touchevents .underlined-btn:hover:after,.underlined-btn.active:after,.underlined-btn:active:after{width:100%}</style><style data-vue-ssr-id="64c6f75c:0">.nuxt-progress{position:fixed;top:0;left:0;right:0;height:2px;width:0;transition:width .2s,opacity .4s;opacity:1;background-color:#efc14e;z-index:999999}</style><style data-vue-ssr-id="1c5e99ea:0">#main[data-v-cac63c14]{padding-top:calc(9.375rem + 4.6875rem + var(--header-banner-h,0px))}@media (max-width:1100px){#main[data-v-cac63c14]{padding-top:calc(9.375rem + 2.5rem + var(--header-banner-h,0px))}}@media (max-width:767px){#main[data-v-cac63c14]{padding-top:calc(95px + 1.25rem + var(--header-banner-h,0px))}}</style><style data-vue-ssr-id="07855964:0">.header-banner[data-v-3bf67506]{background:#001325}.banner[data-v-3bf67506]{position:fixed;z-index:10;overflow:hidden;font-family:IBM Plex Sans,sans-serif;font-weight:700;font-style:normal;text-align:center;color:#fff;line-height:1;width:100vw;padding-top:5px;padding-bottom:5px}.banner.yellow[data-v-3bf67506]{background:#f7dd48!important}.banner.peach[data-v-3bf67506]{background:#ffaf86!important}.banner.sea-blue[data-v-3bf67506]{background:#05728b!important}.banner.dusky-blue[data-v-3bf67506]{background:#42548a!important}.banner.seafoam[data-v-3bf67506]{background:#5fd9aa!important}.banner.wisteria[data-v-3bf67506]{background:#bf86bf!important}.banner.teal[data-v-3bf67506]{background:#2bd6d0!important}.banner.blue[data-v-3bf67506]{background:#10069f!important}.banner.dark-blue[data-v-3bf67506]{background:#00175c!important}.banner.purple[data-v-3bf67506]{background:#6c006c!important}.banner.amplify-blue[data-v-3bf67506]{background:#3f4aeb!important}.banner.amplify-pink[data-v-3bf67506]{background:#ff0061!important}.banner.has-url[data-v-3bf67506]{display:inline-block;cursor:pointer;outline:0;user-select:none;-webkit-tap-highlight-color:transparent;touch-action:manipulation;display:block;transition:filter .1s,transform .4s cubic-bezier(.23,1,.32,1)}.banner.has-url.active[data-v-3bf67506],.banner.has-url[data-v-3bf67506]:active,.no-touchevents .banner.has-url[data-v-3bf67506]:active,.no-touchevents .banner.has-url[data-v-3bf67506]:hover{filter:brightness(.98)}.toggle-banner-enter-active[data-v-3bf67506],.toggle-banner-leave-active[data-v-3bf67506]{transition-duration:.5s}.toggle-banner-enter-active .banner[data-v-3bf67506],.toggle-banner-leave-active .banner[data-v-3bf67506]{transition:transform .5s cubic-bezier(.23,1,.32,1)}.toggle-banner-enter .banner[data-v-3bf67506],.toggle-banner-leave-to .banner[data-v-3bf67506]{transform:translateY(-100%)}.switch-banner-enter-active[data-v-3bf67506],.switch-banner-leave-active[data-v-3bf67506]{transition:transform .4s cubic-bezier(.23,1,.32,1)}.switch-banner-enter[data-v-3bf67506],.switch-banner-leave-to[data-v-3bf67506]{transform:translateY(-100%)}.message[data-v-3bf67506]{line-height:1.2}.close[data-v-3bf67506]{display:inline-block;cursor:pointer;outline:0;user-select:none;-webkit-tap-highlight-color:transparent;touch-action:manipulation;font-size:22px;position:absolute;right:10px;height:20px;width:20px;top:2px;padding:5px;transition:opacity .1s}.close.active[data-v-3bf67506],.close[data-v-3bf67506]:active,.no-touchevents .close[data-v-3bf67506]:active,.no-touchevents .close[data-v-3bf67506]:hover{opacity:.7}.close[data-v-3bf67506]:after,.close[data-v-3bf67506]:before{content:"";position:absolute;left:0;height:15px;width:2px;background:#fff}.close[data-v-3bf67506]:before{transform:rotate(45deg)}.close[data-v-3bf67506]:after{transform:rotate(-45deg)}.wysiwyg[data-v-3bf67506] a{color:#fff;text-decoration:underline}</style><style data-vue-ssr-id="4d676567:0">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</style><style data-vue-ssr-id="39e29f64:0">a[data-v-33dfe38a]{display:inline-block;cursor:pointer;outline:0;user-select:none;-webkit-tap-highlight-color:transparent;touch-action:manipulation;transition:opacity .2s,transform .1s}.no-touchevents a[data-v-33dfe38a]:active,.no-touchevents a[data-v-33dfe38a]:hover,a.active[data-v-33dfe38a],a[data-v-33dfe38a]:active{opacity:.85}span[data-v-33dfe38a]{font-size:2rem}.icon-logo-bug[data-v-33dfe38a],span[data-v-33dfe38a]{vertical-align:middle}@media (max-width:499px){.desktop[data-v-33dfe38a]{display:none}}@media (min-width:500px){.mobile[data-v-33dfe38a]{display:none}}.title[data-v-33dfe38a]{font-family:IBM Plex Sans,sans-serif;font-weight:700;font-style:normal;font-size:1.5rem;color:#fff;margin-left:5px}@media (min-width:500px){.title[data-v-33dfe38a]{display:none}}</style><style data-vue-ssr-id="59e06df9:0">.subscribe[data-v-3d723b2c]{width:20rem;height:1.625rem;display:flex;align-items:center;justify-content:center;opacity:1;transition:opacity .3s cubic-bezier(.77,0,.175,1)}@media (max-width:1024px){.subscribe[data-v-3d723b2c]{display:none}}.hide[data-v-3d723b2c]{opacity:0}.hide button[disabled][data-v-3d723b2c],.hide input[data-v-3d723b2c]{cursor:default}.subscribe-form[data-v-3d723b2c]{display:flex;height:100%;width:100%}.subscribe-form.error input[data-v-3d723b2c]{color:#f04772}input[data-v-3d723b2c]{flex:1;border:none;font-size:12px;letter-spacing:.0125rem;height:100%;background:#fff;padding-left:.625rem;color:#001325;padding-top:3px;transition:color .2s}input[data-v-3d723b2c]::placeholder{color:#354858}input[disabled][data-v-3d723b2c],input[disabled][data-v-3d723b2c]::placeholder{color:hsla(0,0%,100%,.5)}button[data-v-3d723b2c]{font-family:IBM Plex Sans,sans-serif;font-weight:700;font-style:normal;font-size:.875rem;color:#fff;letter-spacing:.4px;background:#10069f;border:none;height:100%;padding:.25rem 1.5625rem;margin-right:-1px;transition:background .3s cubic-bezier(.77,0,.175,1)}button[disabled][data-v-3d723b2c]{cursor:not-allowed}button .label[data-v-3d723b2c]{transition:transform .2s;display:inline-block}button[data-v-3d723b2c]:not([disabled]){display:inline-block;cursor:pointer;outline:0;user-select:none;-webkit-tap-highlight-color:transparent;touch-action:manipulation}.no-touchevents button[data-v-3d723b2c]:not([disabled]):active,.no-touchevents button[data-v-3d723b2c]:not([disabled]):hover,button:not([disabled]).active[data-v-3d723b2c],button[data-v-3d723b2c]:not([disabled]):active{background:#3f37b2}.no-touchevents button:not([disabled]):active .label[data-v-3d723b2c],button:not([disabled]).active .label[data-v-3d723b2c],button:not([disabled]):active .label[data-v-3d723b2c]{transform:translateY(2px)}.success[data-v-3d723b2c]{font-size:12px;font-weight:700}</style><style data-vue-ssr-id="083836fb:0">.categories-dropdown[data-v-138e6fc2]{position:relative}.menu[data-v-138e6fc2]{position:fixed;z-index:11;transform:translateX(-100%);background:#fff;padding:.9375rem 1.875rem;font-size:1.125rem;box-shadow:0 .3125rem 1.25rem rgba(24,63,101,.1);border-bottom:3px solid #10069f}.menu.tall-row[data-v-138e6fc2]{margin-top:3.4375rem}.menu.short-row[data-v-138e6fc2]{margin-top:1.875rem}.menu[data-v-138e6fc2]:before{content:"";width:7.5rem;height:.1875rem;background-color:#10069f;position:absolute;right:0;top:0}.menu.v-enter-active[data-v-138e6fc2],.menu.v-leave-active[data-v-138e6fc2]{transition:opacity .2s,transform .5s cubic-bezier(.165,.84,.44,1)}.menu.v-enter[data-v-138e6fc2],.menu.v-leave-to[data-v-138e6fc2]{opacity:0;transform:translate(-100%,.9375rem)}</style><style data-vue-ssr-id="3dbf88d8:0">.categories-hamburger[data-v-7481a0b0]{display:inline-block;cursor:pointer;outline:0;user-select:none;-webkit-tap-highlight-color:transparent;touch-action:manipulation;transition:opacity .2s,transform .1s;display:flex;align-items:center;position:relative;z-index:1}.categories-hamburger.active[data-v-7481a0b0],.categories-hamburger[data-v-7481a0b0]:active,.no-touchevents .categories-hamburger[data-v-7481a0b0]:active,.no-touchevents .categories-hamburger[data-v-7481a0b0]:hover{opacity:.85}.label[data-v-7481a0b0]{font-family:IBM Plex Sans,sans-serif;font-weight:700;font-style:normal;font-size:14px;letter-spacing:1px;text-transform:uppercase;padding-top:2px}@media (max-width:767px){.label[data-v-7481a0b0]{font-size:12px}}.hamburger[data-v-7481a0b0]{margin-left:.625rem}@media (max-width:767px){.hamburger[data-v-7481a0b0]{margin-left:5px}}@media (min-width:768px){.hamburger-button[data-v-7481a0b0],.label[data-v-7481a0b0]{margin-top:-2px}}</style><style data-vue-ssr-id="fa244482:0">.categories.dropdown .category[data-v-1eb2742c]{color:#001325;white-space:nowrap}.categories.dropdown .category a[data-v-1eb2742c]{display:inline-block;cursor:pointer;outline:0;user-select:none;-webkit-tap-highlight-color:transparent;touch-action:manipulation;display:block;padding-top:.9375rem;padding-bottom:.9375rem;transition:transform .5s cubic-bezier(.165,.84,.44,1),color .3s}.categories.dropdown .category:not(.active) a.active[data-v-1eb2742c],.categories.dropdown .category:not(.active) a[data-v-1eb2742c]:active,.no-touchevents .categories.dropdown .category:not(.active) a[data-v-1eb2742c]:active,.no-touchevents .categories.dropdown .category:not(.active) a[data-v-1eb2742c]:hover{transform:translateX(10px);color:#10069f}.categories.dropdown .category:not(.active) a.active[data-v-1eb2742c],.categories.dropdown .category:not(.active) a[data-v-1eb2742c]:active,.no-touchevents .categories.dropdown .category:not(.active) a[data-v-1eb2742c]:active{transform:translateX(8px);transition-duration:.2s}.categories.dropdown .category .text[data-v-1eb2742c]{display:inline-block;position:relative}.categories.dropdown .category .text[data-v-1eb2742c]:before{content:"";position:absolute;bottom:-.5rem;width:0;height:3px;background-color:#f7dd48;transition:width .5s cubic-bezier(.77,0,.175,1)}.categories.dropdown .category .text.active[data-v-1eb2742c]:before,.categories.dropdown .category.active .text[data-v-1eb2742c]:before{width:100%}</style><style data-vue-ssr-id="fe3c8b68:0">.search[data-v-0e9269b8]{position:relative;width:1.125rem;transition:width .5s cubic-bezier(.77,0,.175,1)}.search.open[data-v-0e9269b8]{width:20rem}.short .search[data-v-0e9269b8]{transform:translateY(-2px)}.el-autocomplete[data-v-0e9269b8]{position:relative;top:.0625rem;padding-right:2.25rem;border:none;border-bottom:1px solid #fff;background:#00175c;box-shadow:-5px 0 15px 5px #00175c;width:100%;opacity:0;transition:opacity .2s .2s}.el-autocomplete[data-v-0e9269b8] .el-input__inner{background:0 0;border:none;color:#fff;padding:0;font-size:1rem;line-height:1}.el-autocomplete[data-v-0e9269b8] .el-input__inner::placeholder{color:#fff}.search.open .el-autocomplete[data-v-0e9269b8]{transition:opacity .2s .1s;opacity:1}.icon-search[data-v-0e9269b8]{display:inline-block;cursor:pointer;outline:0;user-select:none;-webkit-tap-highlight-color:transparent;touch-action:manipulation;transition:opacity .2s,transform .1s;font-size:1.125rem;position:absolute;z-index:1;right:0;top:0}.icon-search.active[data-v-0e9269b8],.icon-search[data-v-0e9269b8]:active,.no-touchevents .icon-search[data-v-0e9269b8]:active,.no-touchevents .icon-search[data-v-0e9269b8]:hover{opacity:.85}</style><style data-vue-ssr-id="0a48448c:0">.search-autocomplete-popper .popper__arrow{display:none}.search-autocomplete-popper .el-autocomplete-suggestion__wrap{border-radius:0}.search-autocomplete-popper .result .title{width:100%;overflow:hidden;text-overflow:ellipsis}.search-autocomplete-popper .result .title em{font-style:normal;display:inline-block;position:relative}.search-autocomplete-popper .result .title em:before{content:"";display:block;position:absolute;left:0;bottom:7px;width:100%;height:2px;background-color:#f7dd48}</style><style data-vue-ssr-id="b41cae56:0">header[data-v-8afef09c]{z-index:10;position:fixed;left:0;width:100%;top:var(--header-banner-h,0);transition:top .5s cubic-bezier(.23,1,.32,1)}@media (min-width:768px){header[data-v-8afef09c]{display:none}}.inner[data-v-8afef09c]{width:100%;height:95px;background:#00175c;padding-top:20px;position:relative;z-index:1;color:#fff;overflow:hidden;transition:height .5s cubic-bezier(.77,0,.175,1)}.inner.open[data-v-8afef09c]{height:160px}.top-row[data-v-8afef09c]{display:flex;justify-content:space-between;align-items:center;flex-wrap:wrap}.left[data-v-8afef09c]{display:flex;font-family:IBM Plex Condensed,sans-serif;font-size:12px;color:#5c6f83;letter-spacing:.4px;text-transform:uppercase}.left[data-v-8afef09c],.title[data-v-8afef09c]{font-style:normal}.title[data-v-8afef09c]{display:inline-block;cursor:pointer;outline:0;user-select:none;-webkit-tap-highlight-color:transparent;touch-action:manipulation;transition:opacity .2s,transform .1s;font-family:IBM Plex Sans,sans-serif;font-weight:700;font-size:23px;width:100%;text-align:center;padding-top:15px;letter-spacing:-.4px}.no-touchevents .title[data-v-8afef09c]:active,.no-touchevents .title[data-v-8afef09c]:hover,.title.active[data-v-8afef09c],.title[data-v-8afef09c]:active{opacity:.85}.divider[data-v-8afef09c]{width:1px;height:20px;background-color:#10069f;margin-left:12px;margin-right:12px}.search[data-v-8afef09c]{margin-top:25px;width:100%!important}.search[data-v-8afef09c] .el-input__inner{font-size:24px;letter-spacing:.3px}.search[data-v-8afef09c] .icon-search{font-size:20px;top:3px}</style><style data-vue-ssr-id="08d1c91e:0">.tabs[data-v-7af8a4f0]{position:absolute;top:160px;left:0;right:0;height:calc(100vh - 160px);background:#fff}.tabs.v-enter-active[data-v-7af8a4f0]{transition:opacity .5s,transform .5s cubic-bezier(.165,.84,.44,1) .15s}.tabs.v-leave-active[data-v-7af8a4f0]{transition:opacity .3s}.tabs.v-enter[data-v-7af8a4f0],.tabs.v-leave-to[data-v-7af8a4f0]{opacity:0}.tabs.v-enter[data-v-7af8a4f0]{transform:translateY(15px)}.tabs[data-v-7af8a4f0] .tab-container{height:calc(100% - 50px);overflow:auto;-webkit-overflow-scrolling:touch}.tabs[data-v-7af8a4f0] .contents>*{padding:1.25rem}.tabs .titles[data-v-7af8a4f0] .title{font-family:IBM Plex Condensed,sans-serif;font-weight:700;font-style:normal;letter-spacing:.7px;height:50px}@media (max-width:424px){.tabs .titles[data-v-7af8a4f0] .title{font-size:13px;letter-spacing:.5px}}@media (max-width:374px){.tabs .titles[data-v-7af8a4f0] .title{font-size:12px}}.tabs .titles[data-v-7af8a4f0] .title:not(:first-child){border-left:2px solid #fff}.categories[data-v-7af8a4f0]{padding:0 1.875rem;font-size:24px;letter-spacing:.3px}</style><style data-vue-ssr-id="3410e4a2:0">.titles[data-v-651cdcc0]{display:flex;position:relative;z-index:1}.titles[data-v-651cdcc0]:before{content:"";background-color:#10069f;left:0;top:0;height:3px;position:absolute;z-index:1;transition:all .6s cubic-bezier(.77,0,.175,1);transition-delay:.1s}.titles.count-2[data-v-651cdcc0]:before{width:50%}.titles.count-2.tab-0[data-v-651cdcc0]:before{transform:translateX(0)}.titles.count-2.tab-1[data-v-651cdcc0]:before{transform:translateX(100%)}.titles.count-3[data-v-651cdcc0]:before{width:33.333333333333336%}.titles.count-3.tab-0[data-v-651cdcc0]:before{transform:translateX(0)}.titles.count-3.tab-1[data-v-651cdcc0]:before{transform:translateX(100%)}.titles.count-3.tab-2[data-v-651cdcc0]:before{transform:translateX(200%)}.title[data-v-651cdcc0]{display:inline-block;cursor:pointer;outline:0;user-select:none;-webkit-tap-highlight-color:transparent;touch-action:manipulation;height:3.125rem;display:flex;align-items:center;justify-content:center;background:#ededf1;padding-top:3px;font-family:IBM Plex Condensed,sans-serif;font-weight:700;font-style:normal;font-size:.9375rem;color:#a6a6a6;letter-spacing:.03125rem;text-transform:uppercase;width:50%;transition:color .3s ease-in-out,background .3s ease-in-out}.titles.count-3 .title[data-v-651cdcc0]{width:33.333333333333336%}.no-touchevents .title[data-v-651cdcc0]:hover{color:#001325}.no-touchevents .title[data-v-651cdcc0]:active,.title[data-v-651cdcc0]:active{color:#10069f;background:#fff}.no-touchevents .no-touchevents .title[data-v-651cdcc0]:active:active,.no-touchevents .no-touchevents .title[data-v-651cdcc0]:active:hover,.no-touchevents .title:active.active[data-v-651cdcc0],.no-touchevents .title[data-v-651cdcc0]:active:active,.no-touchevents .title[data-v-651cdcc0]:active:hover,.title:active.active[data-v-651cdcc0],.title[data-v-651cdcc0]:active:active{color:#10069f}.title.active[data-v-651cdcc0]{color:#10069f;background:#fff}.no-touchevents .title.active[data-v-651cdcc0]:active,.no-touchevents .title.active[data-v-651cdcc0]:hover,.title.active.active[data-v-651cdcc0],.title.active[data-v-651cdcc0]:active{color:#10069f}.tab[data-v-651cdcc0]{padding:1.875rem 2.5rem;box-shadow:0 .3125rem 1.25rem rgba(24,63,101,.1)}@media (max-width:580px){.tab[data-v-651cdcc0]{padding:1.875rem 0}}@media (min-width:581px){.tab[data-v-651cdcc0]{display:flex;flex-wrap:wrap;justify-content:space-between}}</style><style data-vue-ssr-id="14505af9:0">@media (max-width:580px){.author-page[data-v-9f2b486c]{padding:1.25rem 0;margin-top:-20px}}.author-box[data-v-9f2b486c]{width:80%;margin:0 auto 3.75rem}@media (max-width:1024px){.author-box[data-v-9f2b486c]{width:100%}}@media (max-width:580px){.author-box[data-v-9f2b486c]{padding-top:2.5rem;background:#fff}.author-box .content[data-v-9f2b486c]{margin-top:0;box-shadow:none}}.image[data-v-9f2b486c]{position:relative;border-radius:50%;margin:0 auto}.content[data-v-9f2b486c]{margin-top:-3.75rem;text-align:center;padding:5rem 3.75rem 1.25rem;background:#fff;box-shadow:0 .3125rem 1.25rem rgba(24,63,101,.1)}.name[data-v-9f2b486c]{font-family:IBM Plex Sans,sans-serif;font-style:normal;font-size:2rem;color:#001325;line-height:1.19;letter-spacing:-.5px;position:relative;padding-bottom:1.25rem;margin-bottom:1.25rem}.name[data-v-9f2b486c]:after{content:"";position:absolute;background:#001325;width:54px;left:calc(50% - 27px);height:3px;bottom:0}.bio[data-v-9f2b486c]{font-family:IBM Plex Serif,serif;font-style:normal;font-size:14px;line-height:1.86;letter-spacing:.2px}.bio[data-v-9f2b486c] a{color:#10069f;transition:color .3s cubic-bezier(.77,0,.175,1)}.bio[data-v-9f2b486c] a:hover{color:#00175c}.social[data-v-9f2b486c]{color:#10069f;text-align:center;font-size:1.5rem;margin:0 auto}.social>[data-v-9f2b486c]{display:inline-block;text-align:center;padding:10px 14px;transition:background .3s,color .3s,transform .1s}.no-touchevents .social[data-v-9f2b486c]>:active,.no-touchevents .social[data-v-9f2b486c]>:hover,.social>.active[data-v-9f2b486c],.social[data-v-9f2b486c]>:active{background:#10069f;color:#fff}.no-touchevents .social[data-v-9f2b486c]>:active,.social>.active[data-v-9f2b486c],.social[data-v-9f2b486c]>:active{transform:translateY(2px)}.social>* span[data-v-9f2b486c]:before{vertical-align:middle}.article-header[data-v-9f2b486c]{font-family:IBM Plex Condensed,sans-serif;font-style:normal;font-size:.9375rem;color:#001325;text-transform:uppercase;position:relative;margin-bottom:2.5rem;text-align:center;font-weight:500;width:100%;letter-spacing:.5px;padding-bottom:1.25rem}.article-header[data-v-9f2b486c]:after{content:"";position:absolute;background:#001325;bottom:0;left:calc(50% - 27px);height:3px;width:54px}.blog-listing[data-v-9f2b486c]{display:flex;flex-wrap:wrap;justify-content:space-between}.blog-listing .blog-card[data-v-9f2b486c]{width:31%;margin-right:0}@media (max-width:1024px){.blog-listing .blog-card[data-v-9f2b486c]{width:45%}}@media (max-width:580px){.blog-listing .blog-card[data-v-9f2b486c]{width:100%}.blog-listing .blog-card[data-v-9f2b486c]:first-child{padding-top:2.5rem}}</style><style data-vue-ssr-id="1c257290:0">.blog-card[data-v-01f7c032]{display:flex;flex-direction:column;position:relative;background:#fff;color:#001325;margin-bottom:3.75rem;width:45%}@media (max-width:1024px){.blog-card[data-v-01f7c032]{margin-right:0}}@media (max-width:580px){.blog-card[data-v-01f7c032]{width:100%;padding-bottom:2.5rem;flex-direction:row;margin-bottom:0}.blog-card .content[data-v-01f7c032]{padding:0 1.25rem!important;position:relative;flex:1;box-shadow:none!important}.blog-card .content[data-v-01f7c032]:after{content:"";position:absolute;bottom:0;left:1.25rem;height:4px;width:40px;background:#44d62c;transition:all .5s cubic-bezier(.77,0,.175,1)}.blog-card .image[data-v-01f7c032]{width:30%;height:100px}.blog-card .image[data-v-01f7c032]:before{padding-top:100%!important}.blog-card .abstract[data-v-01f7c032],.blog-card .author[data-v-01f7c032]{display:none}}.no-touchevents .blog-card:hover .content[data-v-01f7c032]{box-shadow:0 .625rem 1.875rem rgba(24,63,101,.2)}.no-touchevents .blog-card:hover .abstract[data-v-01f7c032]:after{width:75px;background:#44d62c}.blog-card:active .content[data-v-01f7c032],.no-touchevents .blog-card:active .content[data-v-01f7c032]{box-shadow:0 .625rem 1.875rem rgba(24,63,101,.2)}.blog-card:active .abstract[data-v-01f7c032]:after,.no-touchevents .blog-card:active .abstract[data-v-01f7c032]:after{width:75px;background:#44d62c}.blog-card.active .content[data-v-01f7c032]{box-shadow:0 .625rem 1.875rem rgba(24,63,101,.2)}.blog-card.active .abstract[data-v-01f7c032]:after{width:75px;background:#44d62c}.blog-card .content[data-v-01f7c032]{display:flex;flex-direction:column;flex-grow:1;padding:1.875rem;transition:all .4s cubic-bezier(.77,0,.175,1);box-shadow:0 .3125rem 1.25rem rgba(24,63,101,.1)}.blog-card .title[data-v-01f7c032]{font-family:IBM Plex Sans,sans-serif;font-size:1.5rem;line-height:1.25;padding-bottom:1.25rem}.blog-card .abstract[data-v-01f7c032],.blog-card .title[data-v-01f7c032]{font-style:normal;letter-spacing:.2px;position:relative}.blog-card .abstract[data-v-01f7c032]{font-family:IBM Plex Serif,serif;font-size:14px;color:#354858;line-height:1.5;padding-top:1.25rem;margin-top:0;margin-bottom:1.25rem}.blog-card .abstract[data-v-01f7c032]:after{content:"";position:absolute;top:-1.5px;left:0;height:3px;width:40px;background:#44d62c;transition:all .5s cubic-bezier(.77,0,.175,1)}.blog-card .category[data-v-01f7c032]{margin-top:0;letter-spacing:.8px;margin-bottom:.5rem;font-family:IBM Plex Condensed,sans-serif;font-style:normal;font-size:14px;color:#5c6f83;text-transform:uppercase}.blog-card .author[data-v-01f7c032]{color:#10069f;letter-spacing:.1px;line-height:2;font-size:14px;margin-top:auto;position:relative}.blog-card .author .vv-visual[data-v-01f7c032]{margin:auto 0;border-radius:50%}.blog-card .author .name[data-v-01f7c032]{margin-left:50px;font-weight:600}.blog-card .image[data-v-01f7c032]{position:relative;font-size:0}.blog-card .image[data-v-01f7c032]:before{content:"";padding-top:56.25%;height:100%;display:inline-block;vertical-align:middle}.blog-card .image>[data-v-01f7c032]{font-size:1.25rem;display:inline-block;vertical-align:middle}.blog-card.featured[data-v-01f7c032]{width:100%;flex-direction:row}.blog-card.featured .image[data-v-01f7c032]{width:69%}.blog-card.featured .content[data-v-01f7c032]{flex:1}.blog-card.featured .title[data-v-01f7c032]{font-family:IBM Plex Sans,sans-serif;font-style:normal;font-size:2rem;letter-spacing:-.5px;line-height:1.25;padding-bottom:1.25rem;position:relative}.featured[data-v-01f7c032]{transition:box-shadow .4s cubic-bezier(.77,0,.175,1);box-shadow:0 .3125rem 1.25rem rgba(24,63,101,.1)}.featured.active[data-v-01f7c032],.featured[data-v-01f7c032]:active,.no-touchevents .featured[data-v-01f7c032]:active,.no-touchevents .featured[data-v-01f7c032]:hover{box-shadow:0 .625rem 1.875rem rgba(24,63,101,.2)}.featured .content.active[data-v-01f7c032],.featured .content[data-v-01f7c032],.featured .content[data-v-01f7c032]:active,.no-touchevents .featured .content[data-v-01f7c032]:active,.no-touchevents .featured .content[data-v-01f7c032]:hover{box-shadow:none}.desktop-grid .blog-card[data-v-01f7c032]{margin-right:auto}.desktop[data-v-01f7c032]{display:flex}.tablet[data-v-01f7c032]{display:none}@media (max-width:1024px){.desktop[data-v-01f7c032]{display:none}.tablet[data-v-01f7c032]{display:flex}}.blog-row .blog-card[data-v-01f7c032]{width:31%;margin-right:0}@media (max-width:1024px){.blog-row .blog-card[data-v-01f7c032]{width:45%}}@media (max-width:580px){.blog-row .blog-card[data-v-01f7c032]{width:100%}}.image[data-v-01f7c032]{background:#f7f7fa}</style><style data-vue-ssr-id="6091f783:0">.signup[data-v-1f22341e]{display:flex;flex-direction:column;text-align:center;position:relative;background:#fff;color:#001325;margin-bottom:3.75rem;width:31%}.no-touchevents .signup:hover .content[data-v-1f22341e]{box-shadow:0 .625rem 1.875rem rgba(24,63,101,.2)}.no-touchevents .signup:hover .subhead[data-v-1f22341e]:after{background:#10069f;left:calc(50% - 37.5px);width:75px}.no-touchevents .signup:active .content[data-v-1f22341e],.signup:active .content[data-v-1f22341e]{box-shadow:0 .625rem 1.875rem rgba(24,63,101,.2)}.no-touchevents .signup:active .subhead[data-v-1f22341e]:after,.signup:active .subhead[data-v-1f22341e]:after{background:#10069f;left:calc(50% - 37.5px);width:75px}.signup.active .content[data-v-1f22341e]{box-shadow:0 .625rem 1.875rem rgba(24,63,101,.2)}.signup.active .subhead[data-v-1f22341e]:after{background:#10069f;left:calc(50% - 37.5px);width:75px}@media (max-width:1024px){.signup[data-v-1f22341e]{width:45%}.signup .headline[data-v-1f22341e]{font-family:IBM Plex Sans,sans-serif;font-style:normal;font-size:1.5rem;letter-spacing:.2px;line-height:1.17;position:relative}}@media (max-width:580px){.signup[data-v-1f22341e]{width:85%;margin:2.5rem auto}}.content[data-v-1f22341e]{display:flex;flex:1;flex-basis:auto;flex-direction:column;padding:2.5rem;box-shadow:0 .3125rem 1.25rem rgba(24,63,101,.1);transition:all .4s cubic-bezier(.77,0,.175,1)}.image[data-v-1f22341e]{font-size:0;position:relative}.image[data-v-1f22341e]:before{content:"";padding-top:55.55555555555556%;height:100%}.image>[data-v-1f22341e],.image[data-v-1f22341e]:before{display:inline-block;vertical-align:middle}.image>[data-v-1f22341e]{font-size:1.25rem}.headline[data-v-1f22341e]{font-family:IBM Plex Sans,sans-serif;font-weight:700;font-size:2rem;line-height:1.25;margin-bottom:1.125rem}.headline[data-v-1f22341e],.subhead[data-v-1f22341e]{font-style:normal;letter-spacing:.2px}.subhead[data-v-1f22341e]{position:relative;font-family:IBM Plex Serif,serif;font-size:14px;color:#354858;line-height:1.5;padding-top:1.25rem;margin-top:0}.subhead[data-v-1f22341e]:after{content:"";position:absolute;top:-1.5px;left:calc(50% - 20px);height:3px;width:40px;background:#f7dd48;transition:all .5s cubic-bezier(.77,0,.175,1)}form.error input[data-v-1f22341e]{color:#f04772}input[data-v-1f22341e]{color:#c9cfd4;width:100%;padding:.625rem;margin-top:15px;transition:color .2s}input[data-v-1f22341e]::placeholder{text-align:center}input[data-v-1f22341e]:focus{color:#001325}input[disabled][data-v-1f22341e]{color:rgba(0,19,37,.2)}button[data-v-1f22341e]{display:inline-block;cursor:pointer;outline:0;user-select:none;-webkit-tap-highlight-color:transparent;touch-action:manipulation;background:#6c006c;color:#fff;padding:0 2rem;line-height:2.75rem;font-family:IBM Plex Sans,sans-serif;font-style:normal;font-size:14px;font-weight:700;letter-spacing:.3px;margin-top:.9375rem;max-width:none;width:100%;transition:opacity .3s cubic-bezier(.77,0,.175,1)}button[data-v-1f22341e]:hover{opacity:.8}button[disabled][data-v-1f22341e]{cursor:not-allowed}.no-touchevents button[disabled][data-v-1f22341e]:active,.no-touchevents button[disabled][data-v-1f22341e]:hover,button[disabled].active[data-v-1f22341e],button[disabled][data-v-1f22341e]:active{opacity:1}</style><style data-vue-ssr-id="05d57ccc:0">.pagination[data-v-0ec9d6db]{margin:1.25rem auto 0;justify-content:center}.el-pagination[data-v-0ec9d6db],.pagination[data-v-0ec9d6db]{display:flex}.el-pagination[data-v-0ec9d6db] .el-pager{margin:auto .625rem;display:flex;padding-left:0}.el-pagination[data-v-0ec9d6db] li{list-style-type:none;font-family:IBM Plex Sans,sans-serif;font-style:normal;font-size:1.5rem;color:#001325;line-height:1.17;letter-spacing:.3px;padding:.3125rem;margin:0 .625rem;transition:all .3s cubic-bezier(.77,0,.175,1);cursor:pointer}.el-pagination[data-v-0ec9d6db] li.active{border-bottom:3px solid #10069f;margin-bottom:5px}.el-pagination[data-v-0ec9d6db] li:hover{color:#10069f}.el-pagination[data-v-0ec9d6db] button{border:none}.el-pagination[data-v-0ec9d6db] button[disabled=disabled]{display:none}.el-pagination[data-v-0ec9d6db] .el-icon{font-family:icomoon!important;font-style:normal;color:#10069f;vertical-align:super;transition:all .3s cubic-bezier(.77,0,.175,1);cursor:pointer}.el-pagination[data-v-0ec9d6db] .el-icon:hover{color:#001325}.el-pagination[data-v-0ec9d6db] .el-icon-arrow-left:before{content:"\E905"}.el-pagination[data-v-0ec9d6db] .el-icon-arrow-right:before{content:"\E906"}.el-pagination[data-v-0ec9d6db] .el-icon-d-arrow-left,.el-pagination[data-v-0ec9d6db] .el-icon-d-arrow-right,.el-pagination[data-v-0ec9d6db] .el-icon-more{font-family:icomoon!important;pointer-events:none;color:#001325}.el-pagination[data-v-0ec9d6db] .el-icon-d-arrow-left:before,.el-pagination[data-v-0ec9d6db] .el-icon-d-arrow-right:before,.el-pagination[data-v-0ec9d6db] .el-icon-more:before{content:"\E908";vertical-align:sub}@media (max-width:767px){.desktop[data-v-0ec9d6db]{display:none}}.mobile[data-v-0ec9d6db] button,.mobile[data-v-0ec9d6db] li{padding:0}@media (min-width:768px){.mobile[data-v-0ec9d6db]{display:none}}</style><style data-vue-ssr-id="90764d26:0">.max-w[data-v-0d320780]{width:100%}footer[data-v-0d320780]{border-top:1px solid #ededf1;margin-top:5rem;padding:1.25rem 2.5rem 2.5rem;color:#9a9fa5;font-size:14px;display:flex;justify-content:space-between;align-items:center}@media (max-width:767px){footer[data-v-0d320780]{flex-direction:column;margin-top:1.25rem;border-top:none}footer .social[data-v-0d320780]{order:-1;margin-bottom:1.25rem;justify-content:space-between;display:flex;width:200px;font-size:1.5rem}footer .social>[data-v-0d320780]{margin-left:0}footer .left[data-v-0d320780]{flex-direction:column;display:flex}footer .left>[data-v-0d320780]{margin:10px 0!important;text-align:center}}.left[data-v-0d320780]>:not(:first-child){margin-left:1.25rem}.left a[data-v-0d320780]{transition:color .3s}.left a[data-v-0d320780]:hover{color:#001325}.social[data-v-0d320780]{font-size:1rem;color:#10069f}.social>[data-v-0d320780]{display:inline-block;text-align:center;padding:10px 12px;margin-left:.9375rem;background:#ededf1;transition:background .3s,color .3s,transform .1s}.no-touchevents .social[data-v-0d320780]>:active,.no-touchevents .social[data-v-0d320780]>:hover,.social>.active[data-v-0d320780],.social[data-v-0d320780]>:active{background:#10069f;color:#fff}.no-touchevents .social[data-v-0d320780]>:active,.social>.active[data-v-0d320780],.social[data-v-0d320780]>:active{transform:translateY(2px)}</style>
  </head>
  <body data-n-head="layout,class" layout="blog">
		<script>var bodyEl=document.getElementsByTagName("BODY")[0];bodyEl.classList.add("page-enter"),bodyEl.classList.add("page-enter-active"),setTimeout(function(){bodyEl.classList.remove("page-enter"),setTimeout(function(){bodyEl.classList.remove("page-enter-active")},1e3)},0)</script>
    <div id="__nuxt" data-server-rendered="true"><div class="nuxt-progress" style="width:0%;height:2px;background-color:#f7dd48;opacity:0"></div><div id="__layout"><div class="blog-layout" data-v-cac63c14><div class="header-banner" data-v-cac63c14 data-v-cac63c14 data-v-3bf67506><style data-v-3bf67506>:root{--header-banner-h:0px}</style><!----></div><header data-v-cac63c14 data-v-cac63c14 data-v-32b91e3c><div class="mask" data-v-32b91e3c><div class="max-w" data-v-32b91e3c><div class="top-row" data-v-32b91e3c><div class="left" data-v-32b91e3c><a href="/" class="no-scroll nuxt-link-active" data-v-32b91e3c>Visit Amplitude.com</a><a href="/blog" class="scroll nuxt-link-active" data-v-32b91e3c data-v-33dfe38a><span class="icon-logo desktop" data-v-33dfe38a></span><span class="icon-logo-bug mobile" data-v-33dfe38a></span><span class="title" data-v-33dfe38a>Amplitude</span></a></div><div class="right" data-v-32b91e3c><div class="subscribe-wrap" data-v-32b91e3c><div class="subscribe" data-v-32b91e3c data-v-3d723b2c><form data-v-3d723b2c data-v-3d723b2c class="subscribe-form"><input placeholder="Enter your email" auto-complete="email" type="email" data-v-3d723b2c><button disabled type="submit" data-v-3d723b2c><span class="label" data-v-3d723b2c>Subscribe</span></button></form></div></div><div class="nav-wrap" style="display:none" data-v-32b91e3c><div class="categories-dropdown" data-v-32b91e3c data-v-138e6fc2><div class="categories-hamburger" data-v-7481a0b0 data-v-138e6fc2><div class="label" data-v-7481a0b0>Categories</div><div class="hamburger-button hamburger" style="width:27px;padding:3px" data-v-7481a0b0><div class="line" style="background:#fff;height:1px;margin-top:undefined;top:0"></div><div class="line" style="background:#fff;height:1px;margin-top:4px;top:undefined"></div><div class="line" style="background:#fff;height:1px;margin-top:4px;top:0"></div></div></div><div class="menu short-row" style="display:none" data-v-138e6fc2 data-v-138e6fc2><div class="categories dropdown" data-v-1eb2742c data-v-138e6fc2><div class="category" data-v-1eb2742c><a href="/blog/category/product-growth-best-practices" data-v-1eb2742c><span class="text" data-v-1eb2742c>Best Practices</span></a></div><div class="category" data-v-1eb2742c><a href="/blog/category/perspectives" data-v-1eb2742c><span class="text" data-v-1eb2742c>Perspectives</span></a></div><div class="category" data-v-1eb2742c><a href="/blog/category/inspiration" data-v-1eb2742c><span class="text" data-v-1eb2742c>Inspiration</span></a></div><div class="category" data-v-1eb2742c><a href="/blog/category/inside-amplitude" data-v-1eb2742c><span class="text" data-v-1eb2742c>Inside Amplitude</span></a></div></div></div></div><div class="search" data-v-32b91e3c data-v-0e9269b8><div class="el-autocomplete" data-v-0e9269b8 aria-haspopup="listbox" aria-owns="el-autocomplete-7037" role="combobox"><div class="el-input"><!----><input placeholder="Search" autocomplete="off" class="el-input__inner" debounce="0" fetchsuggestions="function () { [native code] }" placement="bottom-start" popperappendtobody="true" popperclass="search-autocomplete-popper" valuekey="value"><!----><!----><!----></div><div class="el-autocomplete-suggestion el-popper search-autocomplete-popper" style="display:none" role="region"><div class="el-scrollbar"><div class="el-autocomplete-suggestion__wrap el-scrollbar__wrap el-scrollbar__wrap--hidden-default"><ul class="el-scrollbar__view el-autocomplete-suggestion__list"></ul></div><div class="el-scrollbar__bar is-horizontal"><div class="el-scrollbar__thumb" style="width:0;transform:translateX(0);ms-transform:translateX(0);webkit-transform:translateX(0)"></div></div><div class="el-scrollbar__bar is-vertical"><div class="el-scrollbar__thumb" style="height:0;transform:translateY(0);ms-transform:translateY(0);webkit-transform:translateY(0)"></div></div></div></div></div><span class="icon-search" data-v-0e9269b8></span></div></div></div></div><nav class="nav-row" data-v-32b91e3c><div class="blog-name" data-v-32b91e3c><a href="/blog" class="nuxt-link-active" data-v-32b91e3c data-v-33dfe38a><span class="icon-logo desktop" data-v-33dfe38a></span><span class="icon-logo-bug mobile" data-v-33dfe38a></span><span class="title" data-v-33dfe38a>Amplitude</span></a></div><div class="categories links" data-v-1eb2742c data-v-32b91e3c data-v-32b91e3c><div class="category" data-v-1eb2742c><a href="/blog/category/product-growth-best-practices" data-v-1eb2742c><span class="text" data-v-1eb2742c>Best Practices</span></a></div><div class="category" data-v-1eb2742c><a href="/blog/category/perspectives" data-v-1eb2742c><span class="text" data-v-1eb2742c>Perspectives</span></a></div><div class="category" data-v-1eb2742c><a href="/blog/category/inspiration" data-v-1eb2742c><span class="text" data-v-1eb2742c>Inspiration</span></a></div><div class="category" data-v-1eb2742c><a href="/blog/category/inside-amplitude" data-v-1eb2742c><span class="text" data-v-1eb2742c>Inside Amplitude</span></a></div><div class="search-placeholder" data-v-1eb2742c data-v-32b91e3c></div></div><div class="search-container" data-v-32b91e3c><div class="categories-dropdown" style="display:none" data-v-138e6fc2 data-v-32b91e3c data-v-32b91e3c><div class="categories-hamburger" data-v-7481a0b0 data-v-138e6fc2><div class="label" data-v-7481a0b0>Categories</div><div class="hamburger-button hamburger" style="width:27px;padding:3px" data-v-7481a0b0><div class="line" style="background:#fff;height:1px;margin-top:undefined;top:0"></div><div class="line" style="background:#fff;height:1px;margin-top:4px;top:undefined"></div><div class="line" style="background:#fff;height:1px;margin-top:4px;top:0"></div></div></div><div class="menu tall-row" style="display:none" data-v-138e6fc2 data-v-138e6fc2><div class="categories dropdown" data-v-1eb2742c data-v-138e6fc2><div class="category" data-v-1eb2742c><a href="/blog/category/product-growth-best-practices" data-v-1eb2742c><span class="text" data-v-1eb2742c>Best Practices</span></a></div><div class="category" data-v-1eb2742c><a href="/blog/category/perspectives" data-v-1eb2742c><span class="text" data-v-1eb2742c>Perspectives</span></a></div><div class="category" data-v-1eb2742c><a href="/blog/category/inspiration" data-v-1eb2742c><span class="text" data-v-1eb2742c>Inspiration</span></a></div><div class="category" data-v-1eb2742c><a href="/blog/category/inside-amplitude" data-v-1eb2742c><span class="text" data-v-1eb2742c>Inside Amplitude</span></a></div></div></div></div><div class="search" data-v-32b91e3c data-v-0e9269b8><div class="el-autocomplete" data-v-0e9269b8 aria-haspopup="listbox" aria-owns="el-autocomplete-2107" role="combobox"><div class="el-input"><!----><input placeholder="Search" autocomplete="off" class="el-input__inner" debounce="0" fetchsuggestions="function () { [native code] }" placement="bottom-start" popperappendtobody="true" popperclass="search-autocomplete-popper" valuekey="value"><!----><!----><!----></div><div class="el-autocomplete-suggestion el-popper search-autocomplete-popper" style="display:none" role="region"><div class="el-scrollbar"><div class="el-autocomplete-suggestion__wrap el-scrollbar__wrap el-scrollbar__wrap--hidden-default"><ul class="el-scrollbar__view el-autocomplete-suggestion__list"></ul></div><div class="el-scrollbar__bar is-horizontal"><div class="el-scrollbar__thumb" style="width:0;transform:translateX(0);ms-transform:translateX(0);webkit-transform:translateX(0)"></div></div><div class="el-scrollbar__bar is-vertical"><div class="el-scrollbar__thumb" style="height:0;transform:translateY(0);ms-transform:translateY(0);webkit-transform:translateY(0)"></div></div></div></div></div><span class="icon-search" data-v-0e9269b8></span></div></div></nav></div></div><!----></header><header data-v-cac63c14 data-v-cac63c14 data-v-8afef09c><div class="inner max-w" data-v-8afef09c><div class="top-row" data-v-8afef09c><div class="left" data-v-8afef09c><a href="/" class="nuxt-link-active" data-v-8afef09c>Visit Amplitude.com</a></div><div class="right" data-v-8afef09c><div class="categories-hamburger" data-v-7481a0b0 data-v-8afef09c><div class="label" data-v-7481a0b0>Categories</div><div class="hamburger-button hamburger" style="width:27px;padding:3px" data-v-7481a0b0><div class="line" style="background:#fff;height:1px;margin-top:undefined;top:0"></div><div class="line" style="background:#fff;height:1px;margin-top:4px;top:undefined"></div><div class="line" style="background:#fff;height:1px;margin-top:4px;top:0"></div></div></div></div><div class="title" data-v-8afef09c><a href="/blog" class="nuxt-link-active" data-v-33dfe38a data-v-8afef09c><span class="icon-logo desktop" data-v-33dfe38a></span><span class="icon-logo-bug mobile" data-v-33dfe38a></span><span class="title" data-v-33dfe38a>Amplitude</span></a></div></div><div class="search open" data-v-8afef09c data-v-0e9269b8><div class="el-autocomplete" data-v-0e9269b8 aria-haspopup="listbox" aria-owns="el-autocomplete-3825" role="combobox"><div class="el-input"><!----><input placeholder="Search" autocomplete="off" class="el-input__inner" debounce="0" fetchsuggestions="function () { [native code] }" placement="bottom-start" popperappendtobody="true" popperclass="search-autocomplete-popper" valuekey="value"><!----><!----><!----></div><div class="el-autocomplete-suggestion el-popper search-autocomplete-popper" style="display:none" role="region"><div class="el-scrollbar"><div class="el-autocomplete-suggestion__wrap el-scrollbar__wrap el-scrollbar__wrap--hidden-default"><ul class="el-scrollbar__view el-autocomplete-suggestion__list"></ul></div><div class="el-scrollbar__bar is-horizontal"><div class="el-scrollbar__thumb" style="width:0;transform:translateX(0);ms-transform:translateX(0);webkit-transform:translateX(0)"></div></div><div class="el-scrollbar__bar is-vertical"><div class="el-scrollbar__thumb" style="height:0;transform:translateY(0);ms-transform:translateY(0);webkit-transform:translateY(0)"></div></div></div></div></div><span class="icon-search" data-v-0e9269b8></span></div></div><div class="tabs" style="display:none" data-v-8afef09c data-v-8afef09c data-v-651cdcc0 data-v-7af8a4f0><div class="titles tab-0 count-3" data-v-651cdcc0><div class="title active" data-v-651cdcc0>Categories</div><div class="title" data-v-651cdcc0>Editors' Picks</div><div class="title" data-v-651cdcc0>Most popular</div></div><div class="tab-container scroll-container" data-v-651cdcc0><div class="tab" data-v-651cdcc0 data-v-651cdcc0><div class="categories dropdown" data-v-1eb2742c data-v-7af8a4f0><div class="category" data-v-1eb2742c><a href="/blog/category/product-growth-best-practices" data-v-1eb2742c><span class="text" data-v-1eb2742c>Best Practices</span></a></div><div class="category" data-v-1eb2742c><a href="/blog/category/perspectives" data-v-1eb2742c><span class="text" data-v-1eb2742c>Perspectives</span></a></div><div class="category" data-v-1eb2742c><a href="/blog/category/inspiration" data-v-1eb2742c><span class="text" data-v-1eb2742c>Inspiration</span></a></div><div class="category" data-v-1eb2742c><a href="/blog/category/inside-amplitude" data-v-1eb2742c><span class="text" data-v-1eb2742c>Inside Amplitude</span></a></div></div></div></div></div><!----></header><div id="main" data-v-cac63c14><div data-v-9f2b486c data-v-9f2b486c data-v-cac63c14><div class="max-w author-page" data-v-9f2b486c><div class="author-box" data-v-9f2b486c><div class="vv-visual image vv-block vv-fill" style="width:120px;height:120px" data-v-9f2b486c><!----><!----><!----><!----><!----><!----><!----><!----></div><div class="content" data-v-9f2b486c><h1 class="name" data-v-9f2b486c>Mike Hutchinson</h1><div class="bio" data-v-9f2b486c><p>CPO at SuperAwesome, Mike Hutchinson is on a mission to make the internet safer for kids by building the kidtech infrastructure needed to power the kids’ internet. He is passionate about building products with both privacy and responsibility at their heart.</p>
</div><!----></div></div><p class="article-header" data-v-9f2b486c>Articles by Mike Hutchinson<div class="blog-listing" data-v-9f2b486c><a href="/blog/how-we-implemented-kid-safe-analytics-with-amplitude" class="blog-card blog-card" data-v-9f2b486c data-v-9f2b486c data-v-01f7c032><div class="image" data-v-01f7c032><div class="vv-visual vv-block vv-fill" data-v-01f7c032><!----><!----><!----><!----><!----><!----><!----><!----></div></div><div class="content" data-v-01f7c032><p class="category" data-v-01f7c032>Inspiration<h4 class="title" data-v-01f7c032>How we implemented kid-safe analytics with Amplitude</h4><p class="abstract" data-v-01f7c032>Mike Hutchinson, Chief Product Officer at SuperAwesome, walks through his team's journey from an internally built analytics system to Amplitude.<div class="author" data-v-01f7c032><div class="vv-visual vv-block vv-fill" style="width:40px;height:40px" data-v-01f7c032><!----><!----><!----><!----><!----><!----><!----><!----></div><p class="name" data-v-01f7c032>Mike Hutchinson</div></div></a><div class="signup" data-v-9f2b486c data-v-9f2b486c data-v-1f22341e><div class="image" data-v-1f22341e><div class="vv-visual vv-block vv-fill" data-v-1f22341e><!----><!----><!----><!----><!----><!----><!----><!----></div></div><div class="content" data-v-1f22341e><h2 class="headline" data-v-1f22341e>Subscribe to our newsletter</h2><p class="subhead" data-v-1f22341e>Give your email, get a weekly round-up of articles about building better products.<form data-v-1f22341e data-v-1f22341e><input placeholder="Enter your email" auto-complete="email" type="email" data-v-1f22341e><button disabled type="submit" data-v-1f22341e>Sign me up</button></form></div></div></div><div class="pagination" data-v-9f2b486c data-v-9f2b486c data-v-0ec9d6db><!----><!----></div></div><div class="max-w" data-v-9f2b486c data-v-0d320780><footer data-v-0d320780><div class="left" data-v-0d320780><span data-v-0d320780>© 2020 Amplitude</span><a href="/terms" data-v-0d320780>Terms of Service</a><a href="/privacy" data-v-0d320780>Privacy Policy</a><a data-v-0d320780 role="button">Cookie Settings</a></div><div class="right social" data-v-0d320780><a href="https://www.facebook.com/AmplitudeAnalytics?utm_source=facebook_organic&utm_medium=social_organic&utm_campaign=blog-social-sharing" data-v-0d320780 target="_blank"><span class="icon-facebook" data-v-0d320780></span></a><a href="https://www.linkedin.com/company/amplitude-analytics?utm_source=linkedin_organic&utm_medium=social_organic&utm_campaign=blog-social-sharing" data-v-0d320780 target="_blank"><span class="icon-linkedin" data-v-0d320780></span></a><a href="https://twitter.com/Amplitude_HQ?utm_source=twitter_organic&utm_medium=social_organic&utm_campaign=blog-social-sharing" data-v-0d320780 target="_blank"><span class="icon-twitter" data-v-0d320780></span></a><a href="/blog/feed.xml?utm_source=rss_organic&utm_medium=social_organic&utm_campaign=blog-social-sharing" data-v-0d320780 target="_blank"><span class="icon-rss" data-v-0d320780></span></a></div></footer></div></div></div></div></div></div><script>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</script><script src="https://5f0f399d93187a0007a0d7e5--amplitude-prod.netlify.app/_nuxt/manifest.c0ed883b98711a671709.js" defer></script><script src="https://5f0f399d93187a0007a0d7e5--amplitude-prod.netlify.app/_nuxt/layouts/blog.791c39dad476873aad55.js" defer></script><script src="https://5f0f399d93187a0007a0d7e5--amplitude-prod.netlify.app/_nuxt/pages/blog/author/_author.b88e9237de353ac7c5ae.js" defer></script><script src="https://5f0f399d93187a0007a0d7e5--amplitude-prod.netlify.app/_nuxt/vendor.306eb1519aa7160e0c03.js" defer></script><script src="https://5f0f399d93187a0007a0d7e5--amplitude-prod.netlify.app/_nuxt/app.80a12529004c1c7c5d3a.js" defer></script><script src="https://cc.cdn.civiccomputing.com/8/cookieControl-8.3.min.js" data-n-head="true" data-body="true"></script>
  

